Home / Networking / Blokiranje P2P saobraćaja u MikroTiku

Blokiranje P2P saobraćaja u MikroTiku

Kako uspešno blokirati p2p saobraćaj

Kao što znamo jedan od velikih problema je ‘glad’ p2p protokola za mrežnim resursima. Pošto je preko web proxy-ja nemoguće zabraniti skidanje .torrent fajlova, koje još rešenje postoji u MiktoTik-u?

Jedno od osnovnih je ugrađena rutina u samom MikroTiku u kombinaciji sa simple queue pravilom.

drop p2pdrop p2p 2

Tu se tu javlja i problem prevelikog broja konekcija koje torrent klijent može da ostvari, što može dovesti do ‘zagušenja’ linka. Broj konekcija se može ograničiti sa sledećom komandom:

/ip firewall filter

add action=drop chain=forward protocol=udp src-address=192.168.x.x in-interface=lan out-interface=adsl src-port=1025-65535 connection-limit=100,32

add action=drop chain=forward protocol=udp src-address=192.168.x.x in-interface=lan out-interface=adsl dst-port=1025-65535 connection-limit=100,32

Optimalan broj konekcija, kao što je i prikazano u primeru, je 100 i ne treba ići na manji broj, jer se može ‘ugušiti’ http saobraćaj. U praksi se ovo rešenje pokazalo nezadovoljavajućim, iz prostog razloga što je bittorent saobraćaj kriptovan i nemogućnost MiktoTika da ga kao takvog prepozna. Kriptovanje torrent saobraća po defaultu nije uključeno, ali se ono kroz torrent klijent (µtorrent) aplikaciju može uključiti

Sledeće rešenje je mnogo efikasnije, i sa njime ćete moći da potpuno blokirate p2p saobraćaj.

Prvo što radimo je blokiranje korisnika da pronađu torente, uz pomoć layer7 nivoa filtriranja

/ip firewall layer7-protocol
add comment=““ name=torrentsites  regexp=“^.*(get|GET).+(torrent|hepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|torrentz

|vertor|h33t|btscene|bitunity|bittoxic|thunderbytes|entertane|zoozle|vcdq|bitnova

|bitsoup|meganova|fulldls|btbot|flixflux|seedpeer|fenopy|gpirate|commonbits).*$“

nakon toga dodajemo komandu u firewalu

/ip firewall filter
add action=drop chain=forward disabled=no layer7-protocol=\ torrentsites

sledeće što radimo je blokiranje DNS pretrage sa istim regex zapisom

/ip firewall layer7-protocol
add comment=““ name=torrent-dns regexp=“^.+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|torrentz

|vertor|h33t|btscene|bitunity|bittoxic|thunderbytes|entertane|zoozle|vcdq|bitnova

|bitsoup|meganova|fulldls|btbot|flixflux|seedpeer|fenopy|gpirate|commonbits).*\$“

i firewall komanda

/ip firewall filter
add action=drop chain=forward comment=“block torrent dns“ disabled=no dst-port=53 \layer7-protocol=torrent-dns protocol=udp

Ovim načinom i ako koriste web proxy i dalje će biti onemogućeno pronalaženje torent sajtova.

Pošto je sve više magnet linkova, umesto .torrent fajlova, u upotrebi moramo ubaciti još neke komande, koje će sprečiti sam download u torent klijentu.

/ip firewall filter
add action=drop chain=forward comment=“keyword_drop“ src-address=192.168.x.x content=torrent 

add action=drop chain=forward  comment=“trackers_drop“ src-address=192.168.x.x content=tracker 

add action=drop chain=forward comment=“get_peers_drop“src-address=192.168.x.x content=getpeers 

add action=drop chain=forward comment=“info_hash_drop“ src-address=192.168.x.x content=info_hash 

add action=drop chain=forward comment=“announce_peers_drop“ src-address=192.168.x.x content=announce_peers

I na kraju imamo potpuno blokiran download

utorrent

Pozdrav od „umreženog“ tima!

About Dragan

Saradnik i autor raznih tema na blogu umrezen.
Scroll To Top