Home / Networking / MikroTik dual wan load balancing with failover

MikroTik dual wan load balancing with failover

Kako podesiti MikroTik da radi sa dva internet linka sa failover-om

Imate dva internet linka i želite da iskoristite oba?Takođe želite da ako jedan link otkaže,automatski pređete na drugi?Naravno MikroTik ima odgovor i na to.

U ovom tutorijalu se nećemo baviti podešavanjem interfejsa,dhcp klijenata,servera,sve to imate u osnovnom uputstvu.Ako za WAN1 i WAN2 koristite dhcp klijent,obavezno isključite opciju Use peer DNS,da ruter ne uzima DNS parametre,nego ćemo ih ručno uneti,na primer Google public dns,da ne bi dolazilo do konflikta.Primere koje ćemo ovde dati su sa statičkim WAN1 i WAN2 adresama.

dns

Krećemo 🙂

Prvo dajemo IP adrese WAN interfejsima

/ip address add address=192.168.x.x/24 interface=wan1
/ip address add address=192.168.x.x/24 interface=wan2

potom markiramo konekcije

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

potom označavamo konekcije koje potiču od samog rutera,i njih hvatamo u output lancu

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

potom prihvatamo konekcije koje dolaze sa lan interfejsa i usmerene su ka wan interfejsima

add chain=prerouting dst-address=192.168.x.x/24 action=accept in-interface=lan
add chain=prerouting dst-address=192.168.x.x/24 action=accept in-interface=lan

sledeće što radimo je ravnomerna raspodela konekcija uz pomoć PCC metode

add chain=prerouting dst-address-type=!local in-interface=wlan2 per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=wlan2 per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

onda označavamo konekcije koje prolaze kroz ruter iz lokalne mreže prema internetu

add chain=prerouting connection-mark=WAN1_conn in-interface=lan action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=lan action=mark-routing new-routing-mark=to_WAN2

potom podešavamo rute,sa gateway-ima,i oznakama ruta i distancama,koje nam označavaju koji nam je primarni a koji sekundarni link

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.x.x routing-mark=to_WAN1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.x.x routing-mark=to_WAN2 distance=2 check-gateway=ping

i na kraju dodajemo maskaradu

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

Naravno sve IP adrese ćete prilagoditi svojim potrebama.Da napomenem da u klasičnom surfu i download-u nećete primetit neku značajnu razliku u brzini,osim naravno rasterećenja linka,ali će zato torent klijenti itekako imati koristi od ovoga 🙂 Drugim реčima iskoristiće u potpunosti oba linka.

Ako želite možete određene korisnike „naterati“ da koriste samo određeni link,to možete uraditi na sledeći način:

prvo pravimo listu IP adresa ili ceo mrеžni opseg.Ove ćemo dati primer da ceo opseg ide preko WAN1 interfejsa

/ip firewall address-list add list=forsiraj_wan1 address=192.168.x.x/24

i onda označavamo konekcije

/ip firewall mangle add chain=prerouting connection-mark=no-mark \  src-address-list=forsiraj_wan1 dst-address-type=!local \ action=mark-connection new-connection-mark=wan1_conn \  passthrough=yes

Naravno,i za WAN2 su ista podešavanja,samo umesto WAN1 stavljate WAN2.

I to bi bilo to.Pozdrav 🙂

Logo#4

 

About Dragan

Saradnik i autor raznih tema na blogu umrezen.
Scroll To Top