Home / Internet / Podešavanje Cisco C8xx rutera za Telekom Srbija ADSL

Podešavanje Cisco C8xx rutera za Telekom Srbija ADSL

Ukoliko imate Cisco router 800 series (C837, C877, C876…), a potrebna su vam podešavanja, prikazaćemo vam primer konfiguracije namenjen za Telekom Srbija ADSL servis. U suštini, isto je i za sve provajdere na teritoriji Srbije, samo se razlikuje username i password.

U okviru konfiguracije postoji par zanimljivih detalja oko konfiguracije ATM dela, Dialer interfejsa i NAT-ovanja pomoću access liste. Na njih ćemo staviti akcenat, pošto ovo ostalo verovatno znate.

Cisco 877 ADSL Router - podesavanje

Cisco 877 ADSL Router

Podešavanje DSL dela u okviru Cisco rutera:

!
interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
dsl enable-training-log
pvc 8/35 
encapsulation aal5snap
pppoe-client dial-pool-number 1
!

Podešavanje Dialer0 interfejsa, koji će pokrenuti PPPoE konekciju:

!
interface Dialer0
description INTERNET KONEKCIJA
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
no cdp enable
ppp pap sent-username HWxxxxxxxx9@xdsl.isp.telekom.yu password 7 xxxxxxxxxx
!

Dodavanje Default Route:

!
ip route 0.0.0.0 0.0.0.0 Dialer0
!

Access lista i NAT Overload:

!
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 10.0.0.0 0.0.0.127
access-list 1 remark LAN
!

 Ethernet0 Interfejs:

!
interface Ethernet0
ip address 10.0.0.1 255.255.255.128
ip nat inside
!

DHCP Server Pool:

!
ip dhcp excluded-address 10.0.0.1 10.0.0.10
!
ip dhcp pool LAN
network 10.0.0.0 255.255.255.128
default-router 10.0.0.1 
dns-server 8.8.8.8
domain-name cisco.home
!

PODESAVANJE TELEKOM IPTV-a NA CISCO RUTERU

Primer full konfiguracije za ADSL + OPEN IPTV.

Credits: Dusan Vuckovic i Optix

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetim e msec
service password-encryption
!
hostname prvi
!
boot-start-marker
boot-end-marker
!
enable secret 5
enable password 7
!
no aaa new-model
!
dot11 ssid mile.voli.cisco
vlan 1
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7
!
ip cef
!
####### NAJVAZNIJE ZA IPTV
no ip igmp snooping
!
bridge irb
!
!
interface BRI0
no ip address
encapsulation hdlc
!
interface ATM0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
dsl o perating-mode auto
dsl enable-training-log
!
interface ATM0.1 point-to-point
description ATM za internet
no snmp trap link-status
pvc 8/35
encapsulation aal5snap
pppoe-client dial-pool-number 1
!
!
interface ATM0.2 point-to-point
description IPTV
ip igmp static-group *
no snmp trap link-status
pvc 8/37
encapsulation aal5snap
!
bridge-group 2
!
interface FastEthernet0
description Internet1
no cdp enable
!
interface FastEthernet1
description IPTVport
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 mode ciphers aes-ccm
!
broadcast-key vlan 1 change 45
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
power local cck 10
power local ofdm 10
power client 17
channel 2462
station-role root
rts threshold 2312
world-mode dot11d country JP indoor
no cdp enable
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
ip virtual-reassembly
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
ip virtual-reassembly
bridge-group 1
!
interface Vlan2
no ip address
bridge-group 2
!
interface Dialer0
description WAN
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
no cdp enable
ppp pap sent-username adsl.@eunet password 7
ppp ipcp dns request
!
interface BVI1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface BVI2
no ip address
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 remark LAN
!
######## Meni nije ukljucen DHCP jer imam drugi na mrezi. Ako vam treba ne zaboravite da dodate
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 2 protocol ieee
!
line con 0
exec-timeout 0 0
password 7
no modem enable
line aux 0
line vty 0 4
session-timeout 60
access-class 13 in
exec-timeout 60 0
privilege level 15
login local
!
scheduler max-task-time 5000
ntp clock-period 17175085
ntp se rver 147.91.8.77
ntp server 31.19.179.249
ntp server 10.10.192.11
ntp server 212.200.82.130
end

 

About Miloš

Ljubitelj računarskih mreža i interneta. Voljan da pomogne drugima :) Zaljubljenik u sve što ima veze sa mrežama, komunikacijama i bezbednošću na mreži. Cisco i MikroTik sertifikovani inženjer. Obožava digitalnu fotografiju.
Scroll To Top